Authentication System Maintenance
Resolved
May 13, 2026 at 2:16am UTC
We implemented a temporarily patch, this should allow users to proceed with their sessions.
Affected services
Updated
May 13, 2026 at 2:16am UTC
Maintenance ended
Affected services
Updated
May 12, 2026 at 10:44pm UTC
Due to SMTP error, the Email Providing service will be unavailable for the next 24 hours.
Affected services
Updated
May 12, 2026 at 10:43pm UTC
We are currently awaiting a response from the Amazon Web Services support team. We will provide updates as necessary.
Affected services
Created
May 12, 2026 at 3:55pm UTC
Dashboard and any website that is connected to Mk-7 SSO Network will be unavailable. We are currently implementing a new email verification system for the new accounts and currently existing ones.
Affected services